SOLVED Mitres not joining tightly on Polycore moulding

Discuss Picture Framing topics.

PLEASE USE THE HELP SECTION
WHEN SEEKING OR OFFERING HELP!
Post Reply
boscawen46
Posts: 84
Joined: Sun 04 Sep, 2011 7:35 am
Location: gillingham, dorset
Organisation: james frederick
Interests: framing,woodwork

SOLVED Mitres not joining tightly on Polycore moulding

Post by boscawen46 » Wed 28 Jul, 2021 6:07 pm

I posted a message for advice yesterday because while making batches of frames from Polycore I was having problems getting the joints to be tight. When the clamps on the pneumatic Minigraf 4 underpinner held the moulding and the wedge was fired in it pulled the corners apart only slightly but enough to create an annoying gap.

I tried taking the front rebate clamp that moves forward off the machine( it just lifts off) and now just hold the two pieces in place by hand. When the top clamp comes down it holds the pieces in place as the wedge is fired in. No movement and perfect joints. Hope this might help if someone else has had this problem.

boscawen46
Posts: 84
Joined: Sun 04 Sep, 2011 7:35 am
Location: gillingham, dorset
Organisation: james frederick
Interests: framing,woodwork

Re: SOLVED Mitres not joining tightly on Polycore moulding

Post by boscawen46 » Wed 28 Jul, 2021 6:08 pm

BTW I am using a thin line of viscous suoerglue down the middle of the mitres for extra strength.

Not your average framer
Posts: 11716
Joined: Sat 25 Mar, 2006 8:40 pm
Location: Devon, U.K.
Organisation: The Dartmoor Gallery
Interests: Lost causes, saving and restoring old things, learning something every day
Location: Glorious Devon

Re: SOLVED Mitres not joining tightly on Polycore moulding

Post by Not your average framer » Wed 28 Jul, 2021 8:41 pm

Brilliant news! Glad that you've got it sorted.

:clap: :clap: :clap:
Mark Lacey

“Life is short. Art long. Opportunity is fleeting. Experience treacherous. Judgement difficult.”
― Geoffrey Chaucer

Post Reply